Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: add wuestion in re error

...

Tip
title2016 QuickStart

See (http://lists.apple.com/archives/webobjects-dev/2016/Jan/msg00045.html)

Steps 0-2 (as elaborated below)

0. Install Java 8 (or Java 11 ?)
1.  Install Maven 3
2. Update ~/.m2/settings.xml to include the wocommunity repo

Steps 3–6

3. Install Eclipse 4.5 for Committers (http://www.eclipse.org/downloads/)
4. Install m2e via Help > Install New Software.... (See http://www.eclipse.org/m2e/)
5. Install WOLips
6. Preferences > Maven > Archetypes, Add Remote Catalog
    http://maven.wocommunity.org/service/local/repositories/snapshots/content/archetype-catalog.xml

Done. The WebObjects jars are in the wocommunity repo, so no need to do woinstaller.jar hassle.

...

(a) You can use MacPorts (https://www.macports.org) to install:

Code Block
languagebash
themeEmacslanguagebash
titleMacPorts usage
$ sudo port install maven3

(b) Or similarly via Homebrew (http://brew.sh):

Code Block
languagebash
themeEmacs
languagebash
titleHomebrew usage
$ brew install maven

(c) Or manually by downloading the binary tarball, copying it to /usr/local/, unpacking it, soft linking it and adding the path to your bash_profile:

Code Block
languagebash
themeEmacs
languagebash
titleManual install
$ sudo su
$ cd /usr/local/
$ curl -O http://mirror.tcpdiag.net/apache/maven/maven-3/3.3.3/binaries/apache-maven-3.3.3-bin.tar.gz
$ tar -xzf apache-maven-3.3.3-bin.tar.gz
$ ln -s apache-maven-3.3.3 apache-maven
$ exit
$ cd ~/
$ vi .bash_profile

Then in your bash profile, ensure your path and java home are updated:

Code Block
languagetext
themeEmacslanguagetext
title~/.bash_profile
linenumberstrue
...
export PATH=/usr/local/apache-maven/bin:$PATH
export JAVA_HOME=$(/usr/libexec/java_home)
...

...


Whichever installation approach you've taken, you should now be able to do

...

NOTE: WebObjects must be installed.

NOTE: [ERROR] No plugin found for prefix 'wobootstrap' in the current project and in the plugin groups
[org.apache.maven.plugins, org.codehaus.mojo] available from the repositories
[local (/home/ray/.m2/repository), central (https://repo.maven.apache.org/maven2)] > [Help 1]

What does one do about this error? rrk (ray at ganymede.org) 2022 06-24

See the maven-wobootstrap-plugin documentation for more information and options for specifying a specific version.

...