Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

The "--add-exports" is not required for hotswap but is required to run WebObjects applications in Java 17.

Troubleshooting

a. Some versions of macOS may prevent this java from running because of security quarantining. Try removing quarantine from java folder.

sudo xattr -r -d com.apple.quarantine /Library/Java/JavaVirtualMachines/jbrsdk_dcevm-17_0_1-osx-x64-b164.4

b. In the "Project" menu, "Build Automatically" should be selected for hot swap to work.

DCEVM and Hotswap Agent for Java 8

...