Versions Compared


  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: add in re Ubuntu


If you are using RedHat Enterprise Linux, CentOS or Amazon Linux, stop right there! We now have RPM packages for CentOS and RedHat 5.x/6.x, and Amazon Linux. Read the following instructions instead of this document.

Guess what? If you are using Debian or Ubuntu, packages are also available for your platform (although not yet for Xenial)!

Install Sun Java JDK

1. You should install a Sun/Oracle Java SDK. Use Oracle's installation instructions. Choose the appropriate 32-bit or 64-bit Linux installer, for example jdk-6u27-linux-x64-rpm.bin, and install it.


Make sure to install the correct "bit" version for the OS, e.g. install 64 bit JVM on a 64 bit installation, and a 32 bit JVM on a 32 bit installation! To find that information, do:

Code Block
uname -p

If the response is x86_64, it's a 64 bit system. If the response is i386 or i686, it's a 32 bit system.

Creating symbolic links as follows is useful (alternatively use the 'alternatives' command to manage JVMs):

Code Block

ln -s /usr/java/jdk1.6.0_27 /usr/java/jdk1.6
ln -s /usr/java/jdk1.6/bin/java /usr/bin/java

and you need to change your path in your bash profile (_~/.bash_profile) to have this path :

Code Block


Install the WebObjects frameworks (Optional)


If you embed the frameworks into your applications, you don't need to install the core frameworks on the deployment system. Install them only if your applications don't have the frameworks inside their bundles.

2. Get the WebObjects installer from mDimensionthe wocommunity's Web site :

Code Block

curl -C - -O http


wget http

and install it like this :



sudo java -jar WOInstaller.jar dev54 /opt

You may see an error as the command above finishes, but WO may still be installed.

This command below is what you could do if you did not need the dmg above. Unfortunately there is a bug having to do with downloading via HTTPS and you do not get the WebObjects543.dmg automatically and you need the command above.

    sudo /usr/java/


latest/bin/java -jar WOInstaller.jar 5.4.3 /opt


(You can also install 5.3.3 instead of 5.4.3)
WebObjects frameworks are now installed in /opt/next


WebObjects frameworks are now installed in /opt

Code Block
[root@ ~]# ls -l /opt/next
total 12
drwxr-xr-x 3 root root 4096 Nov  9 08:19 Developer
drwxr-xr-x 4 root root 4096 Nov  9 08:19 Library
drwxr-xr-x 3 root root 4096 Nov  9 08:20 Local

Creating the appserver user and starting wotaskd/JavaMonitor

To follow the conventions from Mac OS X, we will create two users to run wotaskd and Monitor under this user :

Code Block
sudo groupadd appserveradm
sudo useradd -g appserveradm appserver

Edit the bash profile of the appserver,

Code Block
# sudo su - appserver
% vi .bash_profile

and add this line :

Code Block

export NEXT_ROOT=/opt/next; export NEXT_ROOT

and run it manually in your current shell :

Code Block

[appserver@ ~]$ NEXT_ROOT=/opt/next; export NEXT_ROOT
. .bash_profile

3. Now Next, we need to change some permissions. To follow the conventions from Mac OS X, we will create two users to run wotaskd and Monitor under this user :

Code Block

sudo groupadd appserveradm
sudo useradd -g appserveradm appserver

and fix some permissions :


install the Wonder version wotaskd and JavaMonitor.

Code Block
$ mkdir -p /opt/Local/Library/WebObjects/JavaApplications
$ cd /opt/Local/Library/WebObjects/JavaApplications/JavaMonitor.woa/JavaMonitor
chmod 750 /opt/next/Library/WebObjects/JavaApplications/wotaskd.woa/Contents/Resources/
chmod 750 /opt/next/Library/WebObjects/JavaApplications/wotaskd.woa/wotaskd


$ wget
$ tar zpxf wotaskd.tar.gz
$ rm wotaskd.tar.gz
$ wget
$ tar zpxf JavaMonitor.tar.gz
$ rm JavaMonitor.tar.gz

4. Now we need to change some permissions:

Code Block
sudo chown -R appserver:appserveradm /opt/Local
sudo chown -R appserver:appserveradm /opt/Library

5. Now we can start wotask and Monitor

Code Block

[root@ ~]# sudo su - appserver

You can start wotaskd and Monitor, manually, to make sure that they run without any problems :

Code Block

[appserver@ ~]$ $NEXT_ROOT/Local/Library/WebObjects/JavaApplications/wotaskd.woa/wotaskd &
[appserver@ ~]$ $NEXT_ROOT/Local/Library/WebObjects/JavaApplications/JavaMonitor.woa/JavaMonitor -WOPort 56789 &


5. Last step : compiling and installing the Apache module(Should info on properly installing and configuring Apache be its own page? Is it its own page somewhere else already? -rrk)

If your Linux installation don't already have Apache httpd running or installed, you need to install it:

For Ubuntu distributions :

Code Block

sudo apt-get install apache2 apache2.2-common apache2-mpm-prefork apache2-utils apache2-threaded-dev ssl-cert

On that system the relevant command names are apache2ctl and apxs2, and the document root is /var/www (not /usr/local/apache/htdocs as in the example below).


For CentOS, RedHat or Fedora distributions :

Code Block

I found on AWS for apache 2.4 I had to change the yum to: yum install httpd
 httpd24 httpd24-devel   yum install httpd mod_ssl
yum install httpd-devel
 chkconfig httpd on
 /etc/init.d/httpd start

.. default install location is then /etc/httpd

HTTP Adaptor

You can also find First, check if a pre-built binaries of the module already exists at If no pre-built binaries exist for your platform, follow those instructions:

Get the source of the module (adaptor) from Wonder. You only need the Adaptors (and its subfolders) folder.

Code Block


Edit make.config and change the value of ADAPTOR_OS to LINUX. (this can be found in Adaptors directory (JS)) (Adaptors directory is now under %PATH_OF_UNZIPPED_SOURCE%/Utilities )

If using modern Ubuntu (and OpenSuse 11.1 too) releases, you'll find that srandom is missing, so as mentioned on the list (JL) :

Code Block

At line 46 in Adaptor/random.c, just remove the check for WIN32, and use the initialisation
code in that block.  That is, change this:

#if defined(WIN32)
   time_t now;

to this:

   time_t now;

Go to the ApacheXX folder that match your Apache version. In my case, I'm using Apache 2.2 built from source and installed in /usr/local/apache.

In another case I ran 'make CC=gcc' in the Adaptors directory then moved to the Apache2.2 directory. (JS)


org. If you are running CentOS 6.x, you can use the module for CentOS 5.5, it works fine.

Once you have downloaded the module, you can install it with:

Code Block
sudo apxs -i -a -n WebObjects
[root@ Apache2.2]# cp -rp /opt/Local/Library/WebServer/Documents/WebObjects /usr/local/apache/htdocs
[root@ Apache2.2]# cp apache.conf /usr/local/apache/conf/extra/webobjects.conf

In OpenSuse 11.1, using Yast, you need to install the apache_devel, in order to get apxs2. I needed to create a symlink called apxs, pointing to apxs2, in order to run the make correctly.

Code Block
ln -s /usr/sbin/apxs2 /usr/sbin/apxs

If you can't find a adaptor for your Linux platform, you will have to build it

Apache Configuration

Instead of copying the WebObjects directory, you can use a alias to point to the folder inside NEXT_ROOT. In your Apache configuration, add something like :

Code Block

Alias /WebObjects "/opt/Local/Library/WebServer/Documents/WebObjects"

and add a directive to allow fetching files in this directory:

Code Block

<Directory "/opt/Local/Library/WebServer/Documents/WebObjects">
      AllowOverride All
      Order allow,deny
      Allow from all

Or (depending on your Apache configuration) you could use a symbolic link.

You also need, as explained by the adaptor's README file, to add this directive in httpd.conf :

Code Block

<LocationMatch /apps/WebObjects/.*>
    Order allow,deny
    Allow from all

If you don't add it, you will get 403s (Forbidden) HTTP errors.


And edit /usr/local/apache/conf/extra/webobjects.conf to comment the LoadModule WebObjects_module line. You can also change the WebObjectsAlias property, in my case I use /apps/WebObjects. Last step : add the following line in httpd.conf (near the end):

Code Block

Include conf/extra/webobjects.conf

Check for any errors with apachectl configtest, and if everything's ok, you are good to go. You can install your first app, don't forget that your app must be accessible by the appserver user or the appserveradm group. If your app don't start or if Monitor complains about a path, it might be a permission problem.

Jerome Chan told me that you can check if the Apache module is loaded by doing this :

Code Block

/usr/local/apache/bin/apachectl -M

On my installation on OpenSuse 11.1, I had to change the path to the lib64 directory where Apache contains the modules.

Code Block
LoadModule WebObjects_module /usr/lib64/apache2/

Auto Start WOTaskd and WOMonitor

One last thing, you need a init script to start wotaskd and Monitor at boot time. This is the one I wrote :

Code Block


# chkconfig: - 90 20
# description: Provides WebObjects services

# Source function library.
. /etc/rc.d/init.d/functions

export NEXT_ROOT

export PATH


# See how we were called.
case "$1" in
		echo -n "Starting wotaskd and Monitor: "
		su $USER -c "$NEXT_ROOT/Library/WebObjects/JavaApplications/wotaskd.woa/wotaskd -WOPort 1085 &"
		su $USER -c "$NEXT_ROOT/Library/WebObjects/JavaApplications/JavaMonitor.woa/JavaMonitor -WOPort 56789 &"
		echo -n "Shutting down wotaskd and Monitor: "
		WOTASKD_PID=`ps aux | awk '/WOPort 1085/ && !/awk/ {print $2}'`
		MONITOR_PID=`ps aux | awk '/WOPort 56789/ && !/awk/ {print $2}'`
		$0 stop
		$0 start
		echo -n "Usage: $0 {start|stop|restart}"
		exit 1

if [ $# -gt 1 ]; then
	$0 $*

exit 0

You also need to add the script with chkconfig so that everything start up after a reboot. If you named the above script as "webobjects", do :

For CentOS, RedHat or Fedora distributions :

Code Block
sudo /sbin/chkconfig --add webobjects
sudo /sbin/chkconfig webobjects on

For Ubuntu :

Code Block
sudo update-rc.d webobjects defaults

A better choice for Ubuntu (later releases anyway) is to use upstart instead of rc.d. One major benefit is that you can configure upstart to respawn your instance of wotaskd if it crashes unexpectedly. This is an example of our upstart conf for wotaskd:



The scripts are available on GitHub. Grab the two files (womonitor and wotaskd) and copy them into the proper directory.

You will be able to see where the services files should go by searching for others.

Code Block
find /etc /lib -name \*.service

Once a wotaskd.service and womonitor.servcie file are in the proper location, you can start them:

Code Block
sudo service start wotaskd
sudo service start womonitor

You should be deploying as the user "appserver" and, if you have done this, make sure that all files and directories referred to in the service files exist and that the permissions are as they should be and that they are owned by or accessible to the appserver user. All files must be readable, all directories must be readable and executable and scripts must the executable. Make sure to check log file locations as well.

Any errors in these files may make the service fail to start in non-obvious ways. The resulting error messages may not be helpful. The best strategy is to be very careful with the contents of the files. An example service file is below. Running "systemctl status" on the services and carefully examining everything in the output may help you with deployment problems.

Enabling the services will ensure that the services restart after a reboot.

Code Block
sudo service enable wotaskd
sudo service enable womonitor

Here's a systemd unit to put into /lib/systemd/system/wotaskd.service 

Code Block
# systemd unit for wotaskd to run on Ubuntu 16.04 LTS 
# Maik Musall <>, Aug 2016 [Unit]
Description=WebObjects/Wonder wotaskd
Environment="JVM_OPTIONS=-Xms32m -Xmx64m -XX:NewSize=2m"

respawn limit 15 5

        echo "Launching wotaskd"
        su $USER -c "$NEXT_ROOTExecStart=/opt/Local/Library/WebObjects/JavaApplications/wotaskd.woa/wotaskd -WOPort 1085 -Xms32m -Xmx64m >> $WOTASKD_LOG 2>&1"
 Restart=on-failure RestartSec=5      emit wotaskd_running
end script

Drop the above into /etc/init/ (note NOT init.d) and start it initially with:

Code Block
services webobjects start

Problems with Application Responding to WOMonitor/WOTaskd

If your Linux server is a virtual machine or if it has multiple IP addresses, you may find that clicking 'Stop' in WOMonitor has no effect on instances, or that the applications never start (the level just go up and down non-stop). This can usually be solved for all Wonder-based applications running on hosts with such a problem by simply creating the following file (known as the 'Machine Properties' file in Wonder's ERXProperties):

Code Block


And inside that file, add an array property that defines all the IP addresses assigned to your host, for example:

Code Block



To learn more, see the class named WOHostUtilities in ERExtensions framework


If SELinux is enabled on your system, wotaskd won't run because of SELinux policies. You need to run be reachable due to its preventing Apache from opening TCP connections. If you're comfortable with allowing Apache to connect to any TCP ports (including external hosts), you can run the following:

Code Block

sudo setsebool -P httpd_can_network_connect=1

Alternatively, Steven Klassen has written a blog post (Custom SELinux Port Access) that outlines how to create and install a wotaskd SELinux module that specifically allows connections to port 1085.


Be aware that SELinux is enabled by default on CentOS 6.x, you will need to either call the setsebool command or to disable SELinux

Additional Resources

Jonathon Rentzsch WOPlat Project 'WOInstaller + Wonder Web Server Adaptor + OS Support Files'