To edit or add content to this Wiki, you can simply create a new account at http://wocommunity.org/account.

Skip to end of metadata
Go to start of metadata

Method 1: Eclipse Update Manager Install (Preferred Method)

This method is more work, but gives you total control over what you install. This is a good place to start if you already have Eclipse installed, or don't meet the system requirements for the all-in-one installer above.

Method 2: All-In-One Turn-Key Installer (Mac OS X 10.5.2+ Only)

Currently Not Working on Snow Leopard

Please be aware that the installer have Eclipse/WOLips 3.4, when most people are using Eclipse/WOLips 3.5, 3.6 or 3.7.

In addition to Eclipse and the WOLips plugins, this incredibly useful installer contains the Project WOnder Frameworks, Frontbase Database and JDBC Driver, and many other tools and examples useful for WebObjects developers just getting started, or just getting started with WOLips.

The pkg installer includes the following components:

  • Eclipse 3.4
  • WOLips (stable rev)
  • Standard EOGenerator Templates
  • WOTaskd and JavaMonitor launchd scripts
  • Wonder Frameworks (as in pure frameworks)
  • Wonder Framework Jars (in case you prefer the embedded kind...)
  • Wonder API Documentation
  • Wonder RuleModeler
  • Jadclipse
  • Standalone Entity Modeler
  • Frontbase Database + JDBC adaptor + Management Apps + Autostart
  • Uninstaller

This Package requires:

  • Around 350MB disk space
  • Apple Mac OS X 10.5.2+ (Leopard)
  • Apple Xcode 3.0+ Developer Tools (Included on the Mac OS X 10.5 (Leopard) Installer DVD)

You can download the All-In-One installer from:

Method 3: Getting Source Code

The WOLips source code repository is hosted on Github. To download the sources use

git clone https://github.com/wolips/wolips.git WOLips

This will give you read-only access.

WOLips Continuous Build Server

Continuous builds of WOLips are maintained in several forms at http://webobjects.mdimension.com/wolips/.